Details
Related Articles
Manuals & Downloads
Support Videos
What should I do if my S1 Pro leaks water and drops debris when mopping the floor?

If you are experiencing issues with your robot leaking water while cleaning, please refer to the following common causes and solutions to resolve the issue.

If you notice that your Robot is dripping water, please first ascertain whether it is dripping clean water or dirty water.

A. If you confirm that it is clean water and there are only a few drops (about 1-2), please be aware that the water dripping near the base station is residual water from the water-filling port of the robot, which is a normal occurrence.

B. If you confirm that the dirty water is continuously dripping, then there are the following troubleshooting and solutions available.

 

Common Causes:

  1. The bottom of the dirty water tank may be clogged with debris.
  2. The dirty water tank may not be properly installed, causing water to leak.
  3. The filter in the dirty water tank is clogged with debris, preventing dirty water from being sucked into the tank, resulting in dirty water leaking while the robot mops.
  4. The roller mop is clogged with debris.
  5. The robot mopped over an area with a large amount of liquid.
 

Solutions:

  1. Lift the robot horizontally and check for dirt and potential leakage at the bottom of the dirty water tank.
  2. Ensure that the dirty water tank is correctly installed. Please note that the red latch should be in place, and the gaps on both sides should be even.
  3. Check if the dirty water tank filter is clogged with debris. If the filter is dirty or clogged with debris, please rinse the filter thoroughly and use a dry cloth to wipe the dirty water tank.
  4. Rotate the roller mop to check for any debris.
  5. Remove the dustbin and check if there is any water inside.
 

If you have any further questions regarding the S1 Pro, please don't hesitate to contact us for assistance.

What should I do if my S1 Pro leaks water and drops debris when mopping the floor?
Download
Applicable for those products :
Resolved
Unresolved
Copied
76 Results
Mapping Instructions and Tips for the S1 Pro
2270 views/1 likes/2025-04-08 16:30:17
Can't find devices?
3285 views/2 likes/2025-06-04 14:38:57
eufy App Beta Test Install & Rollback & Feedback FAQ
876 views/1 likes/2025-06-04 14:36:35
How do I use eufy cleaning solution with my S1 Pro?
1389 views/2 likes/2025-04-08 16:30:27
What should I do if my S1 Pro triggers error code EB14?
1286 views/1 likes/2025-04-08 16:30:27
View More
Manuals & Downloads
‬⁡‌​⁢‬⁣‬‌⁢⁣‌⁣⁢⁢​⁤​⁣‬‬​‌​​⁣‌⁡‍‬​‬‍⁢⁤‍⁣​‍‌​‬⁢【T8010】【HomeBase 2】EU Declaration
Download
T8113S_EU Declaration of Conformity
Download
eufyCam_2C_Pro_Set_Manual_us
Download
RoboVac 30C_Manual_EN
Download
video_Doorbell_2K_(Wired)_Manual_us
Download
Motion_Sensor_manual_us
Download
RoboVac 35C/25C_Manual_EN
Download
720p_Video_Baby_Monitor_manual_us
Download
HomeVac S11 Go/Reach/Infinity_EN+ES_Manual
Download
eufyCam_2_Pro_Set_Manual_us
Download
Support Videos
How to Connect RoboVac to iOS Devices
eufy 3-in-1 E20: Unboxing and Quick Start Guide Video
How to Install eufy Security Video Doorbell (Wired)
How to set up eufy Security Video Doorbell (Battery-Powered)
How to Install eufy Security Floodlight Camera
eufy Security App Functions
RoboVac X8 Series:How to Connect iOS Devices
eufy 3-in-1 E20: How to Connect to Wi-Fi (iOS/Android)
eufy 3-in-1 E20: How to Control Your Device via the eufy Clean App
eufy Clean WetVac W31: Unboxing Video